Age Of Empires Crashes

View previous topic View next topic Go down

Age Of Empires Crashes

Post  Ephestion on Sun Aug 12, 2012 12:18 pm

Over at the official forum I have noticed people are having some problems running the game. So hopefully for your rescue, I decided to make this brief guide.

Age Of Empires Online Requirements:
Processor: Dual Core, 2Ghz or higher
Video card: 128 MB Shader 2 supported card or higher
Memory: Win XP SP3/Vista Home Basic – 1GB; Vista Premium, Ultimate/Windows 7 (32 bit) – 1.5GB; Windows 7 (64 bit) – 2.5GB
Hard drive space: 5 GB required for downloads
Internet: Broadband internet required

http://ageofempiresonline.com/en/faq/#q12

If you plan on playing for 15 minutes per day these specs maybe enough. Otherwise, these are the real minimum specs:
Processor: Even a Celeron D 2.4GHz will run the game. Anything better will give you much better performance.
Memory Total on System: For a 32Bit System: 4GB RAM For a 64Bit System: 8GB RAM
Hard-drive Space: 20GB Free
Graphics Card: This is the most important, Nvidia Ti 550 or Nvidia 570 or Higher. You can match ATI cards for the same specs as I gave you here


Before you install Age Of Empires Online or Game For Windows Live, you need to have .Net Framework 4.0 installed.

The Tips:

Preparing for Installation:
The system requirements skip the part where you probably need some additional software and patches.

First you will need the Microsoft C++ Redistributable. Install this First
http://www.microsoft.com/en-us/download/details.aspx?id=5555

Make sure you install the .Net framework before installing GFWL or AOEO. The reason being some files end up in the wrong locations when you install without the .Net Framework 4.0. Once the Game installed in my root directory eg C:\ drive instead of the proper folder. If you already have installed GFWL or AOEO you may need to uninstall them first, then install the .Net Framework.

http://www.microsoft.com/en-us/download/details.aspx?id=17851

Windows XP user may need a particular patch also:
Try to instal GFWL first and it fails you may need this patch:
Error needing this patch is "Can’t install item (0x800B0003)"
http://support.microsoft.com/kb/960554

Installing
It is best to leave the default locations for the game installation and GFWL installation. It helps if you ever need to read guides to help you fix problems in the future. So go ahead and instal GFWL and the Game now.

Running the Game

1. Start Monitoring
First download the HWMonitor application:
http://www.cpuid.com/softwares/hwmonitor.html

Run this application and not down the temperatures for your system. The main one is your GPU or Graphics Card and the CPU temperature.

If you have temperatures over 60C then you have a hardware system issue. You will need to fix those problems first.
Your CPU on a summer day should never go beyond 80C most operate around 50C. If you have a CPU heating issue you may need to invest in a liquid cooler unit or better air cooler.

2. Start The Game
With HWMonitor still running, start AOEO. I will asume you can make it into the game for this step. Once the game is running press ALT+TAB or ALT+ESC to show the desktop and note any changes to the GPU and CPU temperatures. Keep running the game and possibly play a quest or two and keep checking the GPU and CPU temperatures. Usually you will need to give it around 10 minutes before you will notice temperature changes. So keep playing and pressing ALT+TAB to read the HWMonitor readings.
-If you Have Temperatures over 60C then you have heating issues. If it is a CPU issue then you will need to get a better cooler for your CPU. If you have a GPU problem then consider buying a new card, preferably one that meets the minimum requirements listed at the start of the game.

2. Start The Game But it Doesn't
In this case it is most likely a number of software issues. If .Net didn't fix your problems then you will need to try repairing the game files from the game updater window. Make sure the game exists in the directory:
32Bit Windows: C:\Program Files\Microsoft Games\Age of Empires Online\Spartan.exe
64Bit Windows: C:\Program Files (x86)\Microsoft Games\Age of Empires Online\Spartan.exe

If the game is not there, try searching for spartan.exe on your Hardrive. If it is not where it should be then you have a .Net issue. You may need to install the Full 3.5 Framework and the Full .Net 4.0 Framework. The .Net Framework has several downloads and the Full 4.0 version is the one you want.

Ok if you still have problems installing the game and running it you can get more information here:
http://ageofempiresonline.com/en/support_hot/

If the above guide and the additional resources do not help you then you can do one more thing:
1. Open the Start -> Control Panel
2. Select the Administrative Tools Icon and double click it
3. Select Event Viewer and double click it
This will bring up system events that were logged by your Operating System.
4. Select Windows Logs -> Application Logs: Look for Red icons in the list of log events usually found on the right-hand pane. If you find any that occurred around at the exact time you started the game and it failed, then report them at the official forums: http://forums.ageofempiresonline.com/forums/default.aspx?GroupID=8

You can also post in these forums with your questions.

Ephestion

Posts : 5
Join date : 2011-01-24

Character sheet
HP:
1/1  (1/1)
Hit Dice:
AC: 9

View user profile

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum